Degraded Performance: gitStream for Bitbucket Cloud

Minor incident GitStream gitStream for BitBucket Cloud
2026-07-08 11:00 IDT · 5 days, 5 hours, 5 minutes

Updates

Resolved

What Happened
We resolved an issue where gitStream automations were skipping on Bitbucket Cloud PRs. This was caused by a recent Bitbucket platform update that drastically reduced the allowed size for pipeline variables from 512 KB to 10 KB, causing larger PR payloads to be blocked.

Resolution
We have deployed a fix that compresses the payload data, allowing gitStream to fit well under Bitbucket’s new limits and function normally.

What about historical data / skipped PRs?
To have gitStream process any active PRs that were skipped, you’ll need to push a new commit to those PRs, which will trigger gitStream to run again.

July 13, 2026 · 16:05 IDT
Investigating

Next Update: We will provide our next progress update on Sunday (July 12th), or sooner if new information becomes available.

July 9, 2026 · 19:12 IDT
Investigating

We have received confirmation that this payload reduction was an intentional update by Atlassian, though it has not yet been reflected in Bitbucket’s official API documentation.
Our engineering team is currently evaluating a few potential solutions to bypass this new payload size restriction will provide more definitive guidance on required changes and timelines soon.

July 9, 2026 · 15:23 IDT
Investigating

Identified - We have identified the root cause of the widespread service disruptions affecting gitStream for Bitbucket Cloud.

The issue stems from an unannounced upstream regression within Bitbucket Cloud’s webhook services, which drastically capped maximum payload sizes from approximately 120K down to 10K.
Because gitStream relies on these payloads to receive essential PR context (such as diffs, contributors, and comments) to evaluate automation rules, the majority of PR webhooks are currently failing to process.

As this is an unintended limitation on Atlassian’s side, there is no immediate workaround available on our end.
We are actively tracking the issue with Atlassian support to ensure a resolution is prioritized.

We will continue to share updates here as soon as they become available.

July 9, 2026 · 11:33 IDT

← Back