PM Data Ingestion Degradation
Minor incident
Web APP
Project and Team Delivery
2026-06-08 00:00 IDT
· 13 hours, 1 minute
Updates
Resolved
June 8, 2026 · 12:56 IDT
We have fully resolved the issue affecting our project management data processing pipeline.
A permanent fix has been deployed, and our engineering team has successfully caught up on all delayed processing. All data is now fully restored and completely up to date.
Investigating
June 8, 2026 · 11:02 IDT
We identified a delay in Project Management (JIRA/Azure Boards) data ingestion and processing. The system is currently catching up, and our team is actively working to restore normal processing times as quickly as possible.
← Back
The Engineering Productivity Platform